Unplanned Outage of Worldline EU Acquiring Host

Incident Report for Switchio Status Portal

Resolved

We are pleased to confirm that the system outage was fully mitigated.
Posted Sep 23, 2025 - 12:50 CEST

Investigating

We are currently experiencing an unplanned service outage in production that might affect you. Our technical teams are actively working to resolve the issue.
Posted Sep 23, 2025 - 12:35 CEST
This incident affected: PCI Host Channels (Worldline EU Acquiring Host).