Unplanned Outage of IT CARD Processing Centre

Incident Report for Switchio Status Portal

Resolved

We are pleased to confirm that the system outage was fully mitigated.
Posted Oct 06, 2025 - 11:13 CEST

Investigating

We are currently experiencing an unplanned service outage in production that might affect you. Our technical teams are actively working to resolve the issue.
Internal ticket MONET+ TSGCTCNAG-794177
Posted Oct 05, 2025 - 02:19 CEST
This incident affected: PCI Host Channels (IT CARD Processing Centre).