The service outage from March 23 at 01:30 to March 25 at 16:20 was caused by an problem in processor BENEFITPLUS-BIC infrastructure.
Posted Mar 25, 2026 - 18:44 CET
Resolved
The estimated time of resolution is in the afternoon.
Posted Mar 25, 2026 - 15:15 CET
Update
An issue has been detected on the issuer/processor side. They have confirmed they are working on a fix, estimated time of resolution is not yet available.
Posted Mar 23, 2026 - 06:17 CET
Update
Problem detected at the issuer/processor side. They have been contacted. No reply so far.
Posted Mar 23, 2026 - 05:34 CET
Update
Problem detected at the issuer/processor side. They have been contacted. No reply so far.
Posted Mar 23, 2026 - 04:50 CET
Update
Problem detected at the issuer/processor side. They have been contacted. No reply so far.
Posted Mar 23, 2026 - 01:51 CET
Investigating
We are currently experiencing an unplanned service outage in production that might affect you. Our technical teams are actively working to resolve the issue. Internal ticket MONET+ TSGCTCNAG-897092
Posted Mar 23, 2026 - 01:30 CET
This incident affected: NonPCI Host Channels (Benefit Plus Card Management System).